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Introduction

Welcome to Gradekeeper!
Gradekeeper is a powerful tool for managing your gradebook.  With
Gradekeeper you can:

• Have 250 students per class

• Have 100 assignments per term

• Group assignments into 10 categories

• Excuse individual assignments for any student

• Drop the “worst” score in one or more categories

• Compute grades based on total points or category weights

• Assign letter grades based on your own letter grade cutoffs

• Have final exams contribute to term, semester, or final grades

• Keep every score and assignment for the entire school year

• Divide your school year into two, three, four, or six terms

• View or print a variety of helpful reports such as: class grades,
attendance, individual student scores, and missing assignments

• Export this information for use in letters and reports using your
favorite word processor

Gradekeeper is very easy to use.  The default options allow you to start
entering students, assignments, and scores immediately.  Setting up your
own categories, letter grade cutoffs, and grading options is as easy as
clicking the mouse.

For customer service or technical support on this product, call 
1-888-343-4335

or e-mail custserv@teachercreated.com
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System Requirements and Installation

Macintosh® System Requirements

Macintosh® Installation
1. Insert the Gradekeeper Installation CD-ROM into the computer’s 

CD-ROM drive.
2. Double-click Gradekeeper Installer.
3. Select the folder where you want to install the program.
4. Click the Install button.

PowerMac 

System 8.1 or later, or OS X.

2 MB available RAM

2X CD-ROM Player for installation
(minimum)

2 MB of free disk space

Windows® 95/98/2000 System Requirments

Windows® Installation
1. Insert the Gradekeeper Installation CD-ROM in to the computer’s 

CD-ROM drive.
2. Double-click the gk522.exe icon.
3. Follow the on-screen instructions.

Windows 95, 98, 2000, Me, or NT 4.00 or
later. 

2 MB available  RAM

2X CD-ROM Player for installation
(minimum)

2 MB of free disk space
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Getting Started with Gradekeeper
Creating a new class with Gradekeeper takes only a few minutes.  Double-
clicking the Gradekeeper icon will create a new class.  Before entering any
students or assignments, take a moment to set up a few things.  Keep in
mind that these options can be changed at any time.

Click the first item in the upper left part of the gradebook grid and type
your school name, hit return (enter) and type the name of this class, then
hit return (enter) and type your name.  Hit return (enter) again.

Choose Gradebook Options from the Gradebook menu.  Click the
School Year tab.  School year options determine the number of terms in
the school year, when each term begins and ends, and which days of the
week are included in the attendance grid.

Use the pop-up menu to choose the number of terms in your school year.
Gradekeeper will estimate the starting and ending dates of each term.
Adjust these dates as needed.  Use the tab key to move from item to item.
Click the check boxes for each day of the week to be included in your
attendance grid.

Click the Categories tab.  Assignment categories help organize
assignments.  If grades are computed using category weights, the category
weights will determine how much various assignments will contribute to
the term grade.  If grades are computed using total points earned,
category weights will be ignored.

New classes start with two categories: Tests and Homework.  These can be
changed or your own categories and weights can be added.  Use the tab
key to move from item to item.

Click the Grading tab.  Grades can be computed using total points earned
or category weights.  You can choose to round percents to the nearest
whole percent or the nearest tenth of a percent.  Also, the worst score in
one or more categories can be dropped.  If final exams are given, the
percentage exams will contribute to the term, semester, or final grade for
the year can be determined.  If final exams are not given, these options are
ignored.

Click the Letter Grades tab. Letter grade cutoffs determine how
percentages are converted into letter grades.  An item can be left blank if
a particular letter grade is not used.  Use the tab key to move from item to
item.

Click the Scores tab. Enter the special scores you use for things like
excused assignments. Use the tab key to move from item to item. Use the
pop-up menus to choose whether each special score will be excused or
count as zero points. Click OK when you are done.
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Getting Started with Gradekeeper (cont.)

Click the Attendance tab.  Type in each code used to record attendance.
Use the tab key to move from item to item.  Use the pop-up menus to
choose whether each code will contribute to the total number of tardies or
absences or if it will be excused.

Now you are ready to enter student names and assignments.  To enter
students’ names into the gradebook, click the student column in the first
blank row of the gradebook.  Type in each student name, hitting the
return (enter) key after each name.  It is usually best to enter student
names with the last name first.  Hit the esc key when you are finished.

To enter an assignment into the gradebook, click the top portion of the
first blank column in the gradebook.  Enter the assignment name,
category, and points possible.  Hit the return (enter) key after each item.
Next, enter a score for each student.  Hit the return (enter) key after each
item.  Hit the esc key when you are finished.

When the task of entering students’ names and assignments has been
completed, save your work.  Choose Save As from the File menu.  Enter
the name of your class, then click the Save button.



8

The Gradebook
When creating a new class or opening an existing one, Gradekeeper will
display the gradebook for that class.  Student names, IDs, or both may be
shown.  Students are listed along the left side. Assignment names,
categories and points possible are listed along the top.  Scores are on the
lower right.

Use the scroll bars to see other students or assignments in the gradebook.

To change the school name, class name, teacher name, or to edit students’
names, assignments, categories, points possible, or scores, first choose
Gradebook from the Reports menu.  Then: 

• Click on the item to be changed

• Type in the new text or edit the existing text

• Press return (enter) to accept the changes or esc to cancel

Leave a score blank to indicate a missing assignment.  Enter “exc” to
excuse an assignment.  Enter “inc” to mark an assignment as incomplete
(this is the same as excusing the assignment).  Enter “ab” to indicate a
student was absent for an assignment (this is the same as a score of zero
on that assignment).
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The Gradebook (cont.)

When you are editing a category, Gradekeeper will predict the category as
it is typed.  Only one final exam is allowed in any term.

The arrow keys or the tab key can also be used to accept changes and
move to another item.

Adding Students or Assignments
To add one or more new students to the gradebook:

• Click the student name field in an empty row

• Enter a name for each new student and press the return (enter)
key

• Press the esc key when all names have been entered

It is usually best to enter student names with the last name first.  Students
can be sorted by name, ID, or term grade.  To sort students, choose the
appropriate sort command from the Edit menu.

To excuse all assignments for any students added to an existing class, enter
“exc” for the student’s first score, then choose Fill Across from the Edit
menu.  This will make every score in that row equal to the one just
entered.

To add a new assignment to the gradebook:

• Click the assignment name field in an empty column

• Enter the name, category, and points possible for the assignment

• Enter a score for each student in the class (use “exc” to excuse
an assignment)

If most of the scores being entered are the same, type the first score (do
not hit return [enter]), then choose Fill Down from the Edit menu.  This
will make every score in that column equal to the one just entered.
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The Gradebook (cont.)

Extra Credit Assignments
Gradekeeper provides three ways to give students extra credit: the student
can be given more points than the points possible for an assignment; an
extra credit assignment with zero points possible can be created; or an
assignment can be created and placed into the Extra Credit category. 

See the section on grade computation for more details about how each of
these methods of offering extra credit will affect student grades.

Moving Students or Assignments
Students and/or assignments can be moved within the gradebook by
dragging them.

To move a student or an assignment:

• Click the number of the student or assignment to be moved

• Hold the mouse button down and drag it to the new location

• Release the mouse button to place the item in the new location

Use Cut and Paste to move a student into another class or to move an
assignment into another term.  

To move a student into another class:

• Click the row number of that student

• Use Cut to remove the student from the class

• Save changes to the first class

• Open the other class

• Select the row in which the student’s name should be inserted

• Use Paste to insert the student into the new class

Be careful when moving students into another class, as scores for the
moved student may not exactly match the assignments in the new class.
Gradekeeper will attempt to warn you when this happens.

To move an assignment into another term:

• Click the column number of that assignment

• Use Cut to remove the assignment from the term

• Choose another term from the Gradebook menu

• Select the column in which the assignment should be inserted

• Use Paste to insert the assignment into the new term
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The Gradebook (cont.)

Dropping Students or Assignments
To completely remove a student or an assignment from the gradebook:

• Click the number for that student or assignment

• Choose Cut from the Edit menu

To drop a student from a class without removing them from the
gradebook:

• Click the number for that student

• Drag that student apart from the rest of the students

Students in any row after the first blank row in the gradebook are
considered dropped.  Grades are not computed for these students and
they are not included in any reports.

Adding Final Exams to the Gradebook
To add a final exam to the gradebook, use the “Final Exams” category. You
may have more than one final exam in a term. When there is more than
one final exam in a term, the total points earned and total points possible
are used when computing grades. All semester exams should be placed in
the last term of the semester. Year-end exams should be placed in the last
term of the school year.
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The Attendance Grid

The Attendance Grid
Attendance information for the entire school year can be recorded in the
attendance grid.  Student names, IDs, or both may be listed.  Students are
listed along the left side.  Dates in the current term are listed along the
top.  Attendance information is displayed on the lower right.

Use the scroll bars to see other students or dates.

To change attendance information, click the item to be changed.  Enter the
new attendance code.  Gradekeeper will predict the attendance code as it
is typed.  Attendance for a single day can be printed by clicking once on
the column number for the day you want, then choosing Print from the
File menu.
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The Seating Chart
The seating chart allows you to easily assign students to seats. You can
also take attendance for the current date. To take attendance, control click
on a student’s seat and choose the attendance code you want from the
menu that appears. You can also hide seats or mark seats as unavailable by
right clicking an empty seat and choosing the option you want from the
menu that appears.

To move a student within the
current seating chart, click and
drag the student name to a new
seat. If there is already a student
in the new seat, those students
will exchange seats.

To assign all students to new
seats, choose Assign Seats from
the Reports menu. The assign
seats dialog will appear:

Enter the number of rows and columns in your seating chart. If you are
setting up your seating chart for the first time, you may not want to assign
your students to seats immediately. Uncheck Assign students to seats
and click OK. This will allow you to adjust your seating arrangement by
hiding seats or marking some seats as unavailable.

If you do want to assign all your students to new seats, check Assign
students to seats, and choose how you want to assign seats to your
students. You can assign students to seats randomly or alphabetically by
last name. Click OK to assign all students to new seats using the chosen
method.
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Viewing Reports
Gradekeeper can also display a variety of reports.  To see one of these
reports, choose it from the Reports menu.

Class Grades Report
The Class Grades Report shows every student’s grade for the term.  It also
includes the final exam grade, semester grade, and the final grade for the
year.  The semester grade is only given during the last term of the
semester.  The year grade is only given during the last term of the year.
Averages for the class and a breakdown by letter grade are also provided.
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Viewing Reports (cont.)

Attendance Totals Report
The Attendance Totals Report gives a detailed summary of attendance for
the entire class.  It shows a breakdown by attendance code for each
student in the class for the current term.

Attendance Summary Report 
The attendance summary report shows the total number of tardies and
absences for each student for each term in the current semester or year, as
appropriate. Semester and year totals are included when those options are
chosen in Report Options.
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Viewing Reports (cont.)

The student attendance report is a complete summary of a student’s
attendance. It lists all absences and tardies for each student.

The missing assignments report is a summary of which assignments each
student has not completed. It lists each missing assignment, its category,
and its points possible. Extra credit assignments are not considered missing.
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Viewing Reports (cont.)

Student Scores Report 
The Student Scores Report is a complete summary of a student’s
performance.  It lists every assignment with its category, points possible,
and that student’s score.  Also included is a summary of the student’s
performance by category and by term.
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Viewing Reports (cont.)

Student Summary Report
The student summary report is a summary of a student’s performance. It
includes a summary by assignment category, a summary by term in the
school year, and global and student comments.

Assignment Scores Report 
The Assignment Scores Report lists the score and percentage correct of
every student on every assignment.  It shows the assignment name,
category, and points possible.  It also shows the average score for the class
and a breakdown by letter grade.
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Viewing Reports (cont.)

Missing Assignments Report
The Missing Assignments Report is a summary listing student names with
each missing assignment, its category, and its points possible.  Bonus
assignments are not considered missing.

To see one of these reports, choose it from the Reports menu.

Use the scroll bar to scroll through any report.  In the Student Scores and
in the Assignment Scores reports, it is possible to go directly to a particular
student or assignment.  Click and hold the mouse button down, then
choose the student or assignment from the pop-up menu.
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Multiple Class Report
The multiple class report is a single report showing grades and attendance
for several classes. It is especially useful for elementary teachers who teach
more than one subject in their classroom. To insure that students are
properly matched, it is important to use exactly the same student names
for the same student in each class. Do not use middle initials in one class
and not in another.

To see one of these reports, choose it from the Reports menu.

To create a multiple class report, you must choose the classes to include in
the report. When the file selection dialog appears, select the first class to
include, then hold down the shift key and select the other classes to
include.

If you are using a version of the Mac OS that does not include Navigation
Services (usually Mac OS 8.1 or 8.5), you will need to select one class at a
time. Click Cancel after you have selected all the classes you want to
include in the report.

You can use the scroll bar to scroll through any report. In the student
scores report, multiple class report, and the assignment scores report you
can go directly to a particular student or assignment. Click and hold the
mouse button down, then choose the student or assignment you want
from the pop-up menu.
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Adding Comments
You can add comments to the student scores report. You can add
individual comments for each student, and global comments that will
appear before and after individual student comments. Global comments
will appear on every student scores report.

To add individual student comments, choose Edit Student Comments
from the Edit menu. The student comments dialog will appear:

For each student comment you want to write, choose the student from the
pop-up menu and enter the comment. You can choose to show student
comments or leave them private. Click Done when you are finished.
Comments can be up to 254 characters long.
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Adding Comments (cont.)

To add global comments to the student scores report, choose Edit Global
Comments from the Edit menu. The global comments dialog will appear:

You can enter a comment that will appear before each student comment
and another comment that will appear after each student comment.
Global comments are always shown on the student scores report, even
when individual student comments are not shown. Click OK to accept
your comments, or click Cancel to dismiss the dialog without saving your
changes. Each comment can be up to 254 characters long.

Adding Footnotes
You can add a footnote to any score. To add a footnote, right-click (or
control-click on a Mac) on the score and choose the footnote you want
from the pop-up menu.  You can edit the text for your footnotes by
choosing Edit Footnotes from the Edit menu. The footnotes dialog will
appear:

Type in the text for each footnote you want to use.  Footnotes appear on
the student scores and assignments scores reports and on individual
student web pages created by Gradekeeper. The footnote number appears
in brackets to the left of the score to which it applies.
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Report Options
Gradekeeper also allows you to determine how reports are displayed and
printed.

The Class Grades Report allows the options of whether or not to: include
the final exam grade, semester grade, and final grade for the year; or
include a breakdown by letter grade of class performance during a term.

In the Student Scores Report, it is possible to choose whether or not to:
include a summary of each student’s performance by category and by term
in the school year, show assignments by category, include attendance
information, or include a parent signature line.

The Assignment Scores Report gives a choice of whether or not to include
a breakdown by letter grade of class performance on an assignment.  

The Missing Assignments Report can include all students, or only those
missing assignments.

To choose report options, select Report Options from the Reports menu. 

Click the check box for each item to be included in the specified report.
Click OK to accept changes.  Click Cancel to dismiss the dialog without
making any changes.
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Printing Reports

Printing Reports
To print the gradebook, attendance, or a report, choose that view from the
Reports menu, then choose Print from the File menu.  The standard print
job dialog will appear.  The print job dialog may be different, depending
on the printer you use.

To print only certain pages of a report, enter the starting and finishing
page numbers in the appropriate fields of the dialog box.  The gradebook
and reports are displayed exactly as they will be printed.  The page
indicator in the lower left corner of the window shows the number of the
currently displayed page.

If your printer supports scaling, more information can be printed on each
page.  Some printers do not support scaling.

Macintosh Users: To scale reports, choose Page Setup from the File menu
and choose a smaller scale factor.  

Windows Users: To scale reports, click Properties and choose a smaller
scale factor.  The scale factor item may appear in other locations for some
printers.  

To print the attendance for a single day, first choose Attendance from the
Reports menu, click once on the column number of the specific day to
select it, then choose Print from the File menu.

Moving Into Another Term
To move into another term, select the term from the Gradebook menu.
All scores and assignments are saved for the entire school year.  This makes
it easy to deal with incompletes or to correct mistakes.

When moving into a particular term in the school year for the first time,
categories and grading options will be copied into that term.
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Attendance Codes
The codes used to record attendance can be defined.  Whether or not
each attendance code will contribute to the total number of absences or
tardies can also be determined.

To define attendance codes, choose Gradebook Options from the
Gradebook menu, then click the Attendance tab.

The Attendance dialog will be displayed, showing the current attendance
codes.

Type in a code and choose a category for each attendance code used.  Use
the tab key to move from item to item.  Click OK to accept the changes.
Click Cancel to dismiss the dialog without making any changes.

The possible attendance categories are: Tardy, Excused, Full Absence, and
Half Absence.  The excused category indicates either an excused tardy or
an excused absence.  Excused codes are not included in the total number
of tardies or absences.
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School Year Options
The school year may be divided into two, three, four, or six terms.  The
starting and ending date for each term can be selected.  The days of the
week to be included in the attendance grid can also be chosen.

To set up the school year, choose Gradebook Options from the
Gradebook menu, then click the School Year tab.

The School Year Options dialog will be displayed, showing the number of
terms in the school year with the starting and ending dates of each term.

Choose the number of terms in your school year from the pop-up menu.
Gradekeeper will estimate the first and last day of each term.  Enter the
starting and ending dates for each term, as necessary.  Click the check
boxes for the days to be included in your attendance grid.  Click OK to
accept the changes.  Click Cancel to dismiss the dialog without making
any changes.



27

Assignment Categories
Each assignment must be placed into one of ten categories.  These
categories may be used to compute student grades or simply to organize
assignments.  Progress reports show the percentage correct within each
category.
New classes start off with “Tests” and “Homework” categories.  To change
these categories:
Choose Gradebook Options from the Gradebook menu, then click the
Categories tab.

The Categories dialog will be displayed, showing the current category
names and weights.  The “Final Exams” category is not listed because it
cannot be changed.
Type in a name and weight for each category.  Use the tab key to move
from item to item.  Click OK to accept the changes.  Click Cancel to
dismiss the dialog without making any changes.
Category weights must be between 0 and 100.  Enter a weight of NG to
indicate that assignments in that category should not be included in grade
computation.  The weight could be that category’s percentage contribution
to the term grade, however, the weights do not need to total 100.  It is
possible to have different categories and weights for each term in the
school year.  This allows the flexibility to change how grades are computed
during the course of the year.
Changing category weights does not automatically cause grades to be
computed using those category weights.  This option must be chosen in
the Grading Options dialog.  When computing grades using total points
earned and category weights are changed, you will be asked if the grades
should be computed using the new category weights.
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The Letter Grades dialog will be displayed, showing the current letter grade
cutoffs.  Enter grades and the percentage required to earn each grade.
The buttons on the right may be used to choose the standard A—F system,
the pass—fail system, or the outstanding—satisfactory—unsatisfactory
system.

Use the tab key to move from item to item.  Each percentage must be a
decimal number from 0 to 120.  If a particular grade is not used (if A+
grades are not given), leave the grade and the percentage blank.  Click OK
to accept the changes.  Click Cancel to dismiss the dialog without making
any changes.

Letter grade options affect grades for every term in the school year.

Letter Grades
Letter grade options determine how percentages are translated into
grades.  To change letter grade options:

Choose Gradebook Options from the Gradebook menu, then click the
Letter Grades tab.
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Grading Options
Gradekeeper allows for a variety of grading options.  Grades may be
rounded to the nearest whole or tenth. Final exams may or may not
contribute to the term grade, semester grade, or final grade for the year.
The worst score (the one which, when dropped, will most improve the
grade for a student) can be dropped from one or more categories when
grades are computed (this does not change the score itself).  To set grading
options: 

Choose Gradebook Options from the Gradebook menu, then click the
Grading tab.

Choose the preferred options, then click OK to accept the changes, or
click Cancel to dismiss the dialog without making any changes.

Exam options are only used when there actually are final exams.  If final
exams are to contribute 20% to the semester grade but a final exam is not
given the first semester, that  semester grade will not be affected.  If final
exams are not given, the exam options may be ignored altogether.
Different grading options may be chosen for each term in the school year,
however, exam options apply to the entire school year. 
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Special Scores
You can change the default special scores, change their meanings, or add
special scores of your own. To change your special scores, choose
Gradebook Options from the Gradebook menu and click the Scores
tab. The special scores panel will be displayed, showing your current
special scores.

Enter a score and choose its definition. You can choose to have a special
score count as 0 points, as an excused assignment, or as a pending
assignment (excused, but still considered missing). Use the tab key to move
from item to item. Click OK to accept your changes. Click Cancel to
dismiss the dialog without making any changes.
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Assigning a Password
A password may be assigned to a class to prevent anyone else from
opening the class.  To assign a password to a class:

Choose Gradebook Password from the Gradebook menu.

Enter the current password for the class.  If you have not assigned a
password to this class, leave this item blank.  Enter a new password, then
enter the new password again to verify that it was typed correctly.
Passwords can be from 1 to 15 characters long and are case sensitive.

Write your password down and keep it in a safe place.  If you forget your
password, your registration code can be used instead.  A registered copy of
Gradekeeper must be used in order to assign a password to a class.

Assigning a password to a class only prevents others from opening the
class.  It will not prevent someone from deleting the class.  To fully protect
your classes, consider using software such as At Ease that limits access to
your computer.  Also, always keep a current backup of your classes on
another disk.

When opening a class that has a password, Gradekeeper will ask for that
password.  It will also allow the addition of this password to your
Keychain.  This allows you to keep all your passwords in one place.  The
Keychain is only available with Mac OS 9 or later.
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Importing Students and Assignments
To read a list of students or assignments and scores from a text file, choose
Import from the File menu.  The Import dialog box will appear.

Click the check box for each item to be imported.

Students, assignments, and scores may be imported into an empty class, or
additional students and scores or additional assignments and scores may
be imported into an existing class.  Click Import to continue.  Click Cancel
to dismiss the dialog without importing anything.

The standard file dialog will appear, allowing the selection of the text file
from which this information is to be read.  The students will be added to
the gradebook following any students already in the class.

If importing student IDs and names, the text file should be formatted as
follows:

Id [tab] name [return (enter)]

Id [tab] name [return (enter)]

Id [tab] name [return (enter)]

New students are added after the last existing student but before any
dropped students remaining in the gradebook.  New assignments are
added after any existing assignments.
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Importing Students and Assignments (cont.)

If you are importing student IDs and names, your text file should be
formatted as follows:

id tab name return

id tab name return

id tab name return

New students are added after the last existing student, but before any
dropped students remaining in the gradebook. New assignments are
added after any existing assignments.

If you are importing assignments and scores, your text file should be
formatted as follows:

assignment tab assignment tab … tab assignment return

category tab category tab … tab category return

points tab points tab … tab points return

score tab score tab … tab score return

score tab score tab … tab score return

score tab score tab … tab score return

All students must be included, even if they have no scores for any
assignment. Student scores must be in the same order as those students
appear in your gradebook.

If you are importing dates and attendance, your text file should be
formatted as follows:

date tab code tab date tab code return

date tab code tab date tab code return

date tab code tab date tab code return

You only need to include the dates when a student is absent or tardy.
Different students can have different numbers of dates. All students must
be included, even if they have no absences or tardies. Student attendance
codes must be in the same order as those students appear in your
gradebook.
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Exporting Students and Assignments (cont.)

You may only export exam grades when there is an exam in the current
term. You may only export semester grades when you are in the last term
of the semester. You may only export end-of-year grades when you are in
the last term of the year.

Click Export to continue.

The save dialog will appear, allowing you to specify the name and location
of the text file which will be created. Type in a file name and click Save.

If you are exporting student IDs and names, your text file will be formatted
as follows:

id tab name return

id tab name return

id tab name return

If you are exporting assignments and scores, your text file will be
formatted as follows:

assignment tab assignment tab … tab assignment return

category tab category tab … tab category return

points tab points tab … tab points return

score tab score tab … tab score return

score tab score tab … tab score return

score tab score tab … tab score return

If you are exporting dates and attendance, your text file will be formatted
as follows:

date tab code tab date tab code

date tab code tab date tab code

date tab code tab date tab code

Only those dates when a student is absent or tardy will be included, but all
students will be included.
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Form Letters and Custom Reports
You can use the Export to Text capability of Gradekeeper together with
the mail merge capability of Microsoft Word to create custom form letters
or reports.

First, export the items you want in your report from Gradekeeper:

• Choose Export to Text from the File menu

• Choose the items you want in your report

• Click the Export button

• Choose a name for the text file

• Click the Save button

Next, start Microsoft Word. If you are using a Windows computer, choose
Mail Merge from the Tools menu. The Mail Merge Helper will appear.

If you are using a Macintosh computer, choose Data Merge Manager
from the Tools menu.  The Data Merge Manager will appear.
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Form Letters and Custom Reports (cont.)

In the Main Document section, click Create and choose Form Letters.
You can choose to use the active window or to create a new main
document.

In the Data Source section, click Get Data and choose Header Options.
In the Header Options window, click the Create button. The Create
Header Source window will appear:

Click Remove Field Name until all of the default field names have been
removed. Then enter the field names you want. Your field names must
match the items you exported from Gradekeeper and must be in the same
order that Gradekeeper has them. Click OK when you finish entering your
field names. The standard save dialog will appear. Choose a name for your
header source document and click Save.

In the Mail Merge Helper, in the Data Source section, click Get Data.
Choose Open Data Source.  The standard open dialog will appear.
Choose to show files of type text and choose the text file you exported
from Gradekeeper.
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Form Letters and Custom Reports (cont.)

After you choose your text file, the Header Record Delimiters window will
appear:

You can now type your form letter. To insert one of the items you
exported, drag the appropriate button from the Merge Field section of the
Data Merge Manager into your document.

Choose tab as the field delimiter and enter as the record delimiter, then
click OK.

If you are using a Windows computer, you can now type your form letter.
To insert one of the items you exported, choose it from the Insert Merge
Field button in the toolbar.

If you are using a Macintosh computer, the Data Merge Manager window
should now appear something like this:
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Form Letters and Custom Reports (cont.)

When you are done typing your form letter, it may look like this:

You can now create a merged document by clicking the Merge button in
the toolbar (Windows) or by clicking the new document button in the
Merge section of the Data Merge Manager (Macintosh):

Microsoft Word may warn you about having empty records in your data
source. This warning indicates that there were one or more blank lines in
your text file. You can ignore these warnings.

You can also merge to email

• For Windows computers, an email account and SMTP server
must be set up in Microsoft Outlook. And you need to add a
column to the text file exported from Gradekeeper that has the
email addresses to which you want to send the report.  

• For Macintosh computers, Microsoft Entourage must be set as
your default email application. You will need to insert a column
into the text file for the email address for each student and
include a header for that field.

Once you’ve created a data merge document, you can use the same
document many times. Simply change the data source to the text file you
exported from Gradekeeper and then create a new merged document.
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Form Letters and Custom Reports (cont.)

Your finished product might look something like this:
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Creating a Web Site
To allow students and parents to access grades on the Internet, choose
Export to Web from the File menu.  The Export to Web dialog will
appear:

A single Web page or a complete Web site can be created.  Choose the
option preferred and click OK.  When creating a single Web page, the
standard save dialog will appear.  Enter a name for the Web page being
created and choose the location in which it is to be saved.  

When creating a complete Web site, the Browse for Folder or Choose a
Folder dialog will appear:

Macintosh Windows
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Creating a Web Site (cont.)

Choose a folder for your web site. To create a new folder, choose the
folder you want to create that new folder in (or the desktop), then click
New Folder, then type a name for the new folder. Click OK when you have
chosen a folder.

When you create a single web page, student ID codes will be displayed
with student grades and attendance totals according to your current report
options:

The authorization web page requires a browser that supports Javascript.
Browsers without Javascript enabled will not be able to see student web
pages. The authorization web page is named index.html by default. Most
web servers use this as their default web page name. If your web server
uses a different default name (some servers use Default.html) you should
rename it. If this web page does not have the correct default web page
name for your server, it is relatively easy to bypass the authorization
scheme!

When you create a complete web site, an authorization web page will be
created to ask for a student name and ID code:
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Creating a Web Site (cont.)

If a valid student name and ID code are entered, the corresponding student
web page will be displayed:

After your web page or web site has been created, you must upload it to a
web server and tell students and parents the URL so they can access it.
Your school may have a web site where you could upload these web
pages, or you can use your own web site.
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Uploading Web Pages for Windows
To upload these web pages to your web site, you will need to use an FTP
application. FTP Explorer is an FTP application for Windows. They offer free
licenses to educational users. You can learn more about FTP Explorer at:

http://www.ftpx.com/

You can download FTP Explorer from:

ftp://ftp.ftpx.com/pub/ftpx/ftpx1010.zip

Before using FTP Explorer, you will need to know the address to connect to
(it is usually not the same address you use to access the web pages), your
username, and your password. For example, if you were using Geocities,
you would connect to ftp.geocities.com using your username and
password.

When you start FTP Explorer, you will see the connection dialog.

Enter your host address, login username, and password. You can enter a
profile name so FTP Explorer will save this login information. You may need
to enter an initial path. Do not change the other items. Click Connect.

FTP Explorer will connect to your FTP server using your username and
password. You will see a list of files in your directory:

Rather than upload each individual web page (which would be very time
consuming), you can upload the entire folder that Gradekeeper created,
and let FTP Explorer take care of the rest. Locate the folder that
Gradekeeper created and drag it into the directory listing (but not onto
another folder). FTP Explorer will upload the folder and all its contents to
your web site.

You should always try accessing your grade web site using your own web
browser to make sure everything is exactly the way you expect. The
address of your web folder should be something like:

http://www.geocities.com/dethier/grades/

You should not need to specify index.html when accessing your grades
web site. If you do not specify it and you get a list of the contents of the
folder instead of the login web page, you either did not upload the
index.html web page, or your web server uses a different name for its
default web page. You will need to rename index.html to the file name
your web server uses.
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Uploading Web Pages for Macintosh
To actually upload these web pages to your web site, you will need to use
an FTP application. Fetch is an FTP application created by Dartmouth
College for the Macintosh. A free license is available for schools. You can
download Fetch from
http://www.fetchsoftworks.com/
Before using Fetch, you need to know the address to connect to (it is
usually not the same as the address you use to access the web pages),
your username, and your password. For example, if you were using
Geocities, you would connect to ftp.geocities.com using your username
and password.
When you start Fetch, you will see the new connection dialog.

Enter the host, username, and password. Click OK. Fetch will connect to
your FTP server using your  username and password. You will see a list of
files in your directory:
To upload the web pages, first navigate inside the folder you want them in
(you can create a new folder by choosing Create New Directory from the
Directories menu). Then click Put Files at the bottom of the window. You
will see a dialog that allows you to choose the files to upload:
Select all the web pages you want to upload. You can click the first one,
then shift-click the last one to select them all. The Put Files dialog will
appear, allowing you to choose how the files in the folder will be handled:
The default options are usually the best choice. Click OK. Fetch will now
upload the web pages you selected to your web site.
You should now try accessing your grade web site using your own web
browser to make sure everything works the way you expect. The address
of your web folder should be something like:
http://www.geocities.com/dethier/grades/
You should not need to include “index.html” when accessing your grades.
If you do not include it and you get a list of the contents of the folder
instead of the login web page, you either did not upload the index.html
web page, or your web server uses a different name for its default web
page. You will need to rename index.html to whatever file name your web
server uses.
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Posting Grades Online Using Edline
Edline is a leading web publishing provider for K-12 schools. Edline makes
it easy for your school to provide parents and students with secure online
access to grades and other information. Gradekeeper can work with Edline
to post grades online quickly and easily.

To post grades online, Choose Export to Edline from the File menu. The
Export to Edline dialog will appear. Enter the class ID for this class, then
click OK. Your web browser will open a web page where you can enter
your username and password. Your progress reports will then be uploaded.
Allow the upload to complete. Parents and students can then access all
their grades using their own username and password.

Students must have an ID to be exported to Edline.

Your school must have an account with Edline to post grades there. If your
school has an account with Edline, ask your technology coordinator for
activation instructions. If your school does not have an account with
Edline, visit http://www.edline.com/gradekeeper/gkindex.html
for more information.
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Posting Grades Online Using School Center
School Center was created to help meet the web hosting needs of schools,
administrators, teachers, students, and staff. School Center makes it easy
for schools to provide a functional, easy to maintain web site, whether
they want a simple site or a total web presence. 

To post grades online using School Center, Choose Export to School
Center from the File menu. The Export to School Center dialog will

Enter the class ID for this class, then click OK. The standard save dialog will
appear. Choose where you want to save the XML file and click Save. This
will create an XML file that you can then upload to School Center.

Students must have an ID to be included in the export to School Center.

Your school must have an account with School Center to post grades
there. If your school has an account with School Center, ask your
technology coordinator for instructions. If your school does not have an
account with School Center, visit http://www.schoolcenter.com for more
information.
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Gradekeeper Palm Application
The Gradekeeper Palm application works with Gradekeeper to allow you to
take attendance, edit scores and comments, and add new assignments
using your Palm handheld. It is not a substitute for your desktop copy of
Gradekeeper.

Before you begin using the Gradekeeper Palm application, you must install
the application onto your Palm handheld. To install the application, launch
the Palm Desktop software:

• Click the Install tool

• Click the Add button

• Choose Gradekeeper.prc

• Click the Open button

Gradekeeper.prc is located in the Gradekeeper folder in the Program Files
folder in Local Disk (C:) in My Computer.

Next, you must enable HotSync for each class you want to use on your
Palm handheld. Open each class with Gradekeeper, and choose Enable
HotSync from the File menu. Finally, you must HotSync your Palm
handheld. This will copy the application and classes to your handheld.

When you run the Gradekeeper Palm application, you will see the
students’ view:

You can choose another class by tapping the class name and choosing a
class from the menu that appears. You can choose another student by
tapping the student name and choosing a student from the menu that
appears.

To edit a score, tap it and enter a new score. To add a footnote to a score,
tap the footnote number (or dash, if there is no footnote for that score)
and choose the footnote you want from the menu that appears.
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You can edit scores and footnotes in the assignments view in the same
way you can in the students view. You can edit an existing assignment by
tapping the “i” button. You can add a new assignment by tapping the
“+” button. Both buttons will show the assignment info form:

To enter a comment, tap the comments field and enter your comment.
Student comments can be up to 250 characters in length.

You can choose the assignments view by tapping the Assign push button.

To edit a student comment, tap the “i” button to the right of the student
name. The student info form will appear:

Gradekeeper Palm Application (cont.)
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The assignment info form allows you to change the date, name, category,
and points possible for an assignment. You cannot change the date or
name for an assignment after you do a HotSync. Those items are used to
match assignments on the handheld with assignments in the desktop class.

You can choose the attendance view by tapping the Attend push button.

Gradekeeper Palm Application (cont.)

When you choose the attendance view, today’s date is added to the
database. You can also choose earlier dates by tapping the date and
choosing a date from the menu that appears. Only dates since your last
HotSync are available.

To choose an attendance code for a student, tap the code (or the dash, if
there is no attendance code for that student) and choose a code from the
menu that appears.
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The HotSync Process
When you HotSync, the Gradekeeper conduit does the following:

• Copies all changes and new assignments from the handheld to
the desktop

• Copies all students, recent assignments, and today’s attendance
to the handheld

The Gradekeeper conduit matches students by name and ID. Both must be
equal for the student to be considered a match. The conduit matches
assignments by name and date. Both must be equal for the assignment to
be considered a match. The conduit matches classes by the date and time
it was first created.
The Gradekeeper conduit copies changed scores from the handheld to the
desktop before it copies scores from the desktop to the handheld.
Changed scores on the handheld will always overwrite any changed scores
on the desktop.
This works quite well, and you will usually not even need to think about
how the Gradekeeper conduit does its business. But to avoid losing
information you added on your handheld, you should follow these
suggestions:

• Do not change student names or IDs on the desktop
• Do not change assignment names or dates on the desktop
• Do not move, copy, or rename a class when HotSync is enabled
• Leave enough unused columns in the class for any new

assignments
• Do not change scores for an assignment on the desktop and the

handheld
If you need to change a student name or ID, or an assignment name or

date:
• HotSync your Palm handheld
• Make the changes to the desktop class
• HotSync your Palm handheld again

If you need to move, copy, or rename a class:
• HotSync your Palm handheld
• Disable HotSync for that class
• Move, copy, or rename the class
• Enable HotSync for that class
• HotSync your Palm handheld
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Using Gradekeeper on Different Computers
There may be a reason to use Gradekeeper on both Windows and
Macintosh computers.  For instance, if you happen to have a Windows
computer at home and a Macintosh at school (or vice-versa) you may want
to enter grades on both machines.  The license you purchased allows the
installation of the software on one computer at school and one computer
at home.  Once the software has been installed on both computers, files
can easily be moved between a Macintosh computer and a Windows
computer by following a few simple steps.

Using Macintosh Files on a Windows Computer
When creating a class on a Macintosh computer which might be used on a
Windows computer, include the “.grk” file extension (e.g.: reading.grk).
Be sure to save the file on a Windows formatted disk.  This allows the
Windows version of Gradekeeper to recognize the file as a Gradekeeper
class.

Using Windows Files on a Macintosh Computer (OS 8 and OS 9)
To use classes created by the Windows version of Gradekeeper on a
Macintosh, use the File Exchange control panel (called PC Exchange in Mac
OS 8 and earlier).  The File Exchange control panel lists Windows file
extensions recognized by the Macintosh.

To add the file extension used by the Windows version of Gradekeeper,
click the Add button.
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Using Gradekeeper on Different Computers (cont.)

The Add Mapping dialog will be displayed, allowing the appropriate
extension to be added.

Enter “grk” as the extension.  Locate Gradekeeper from the list of
applications, and select it.  Choose the GRCL document type from the
pop-up menu, then click Add.  Close the File Exchange control panel.

Now, whenever a class created under Windows is transferred to a
Macintosh, it will display the same icon as a class created on a Macintosh.
Double-clicking that icon will open the class with Gradekeeper.  All that is
necessary is to make sure the class has the “.grk” extension.
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Using Windows Files on a Macintosh Computer (OS X)
If you want to use classes created by the Windows version of Gradekeeper
with Mac OS X, you may need to explicitly specify which application should
open the class. Click once on the class icon, then choose Get Info from
the File menu:

Click the triangle to the left of Open with. This will display the Open with
options. From the pop-up menu, choose Other.

Using Gradekeeper on Different Computers (cont.)
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The Choose Other Application dialog will be displayed, allowing you to
specify the application:

Choose All Applications from the Show pop-up menu, navigate and find
the Gradekeeper application and select it. Check Always Open With.
Click Add. Now, when you double click this class icon, it will be opened
using Gradekeeper. In the Get Info window, click Change All to apply this
choice to all Gradekeeper classes.

You can also use the Gradekeeper PC->Mac Applescript applet in the
Gradekeeper folder to convert Windows classes. Drag a class onto the
Gradekeeper PC->Mac icon. The class will be converted to a Macintosh
class.

Using Gradekeeper on Different Computers (cont.)



55

When You Make Mistakes
When a mistake is made or something is changed in a way that was not
intended, that change may be canceled.  Choose Undo from the Edit
menu.  This will restore the gradebook to the way it was before the last
action.

Only the most recent action can be undone.  For instance, if a student has
been cut from one class and pasted into another class, only the paste can
be undone.  There are also a few actions that cannot be undone.

Also, the changes made since last saving the document may be discarded.
Choose Revert from the File menu.  This is equivalent to closing the
document without saving changes and opening it again.

Making Backups
While Gradekeeper has proven very reliable, floppies are easily damaged
and hard drives have been known to fail.  To avoid the risk of losing grades
at the worst possible time, always keep a current backup of your data on
another disk.

Macintosh Users: If running Gradekeeper from the hard drive (suggested),
make a backup by dragging your class icons onto a floppy icon.  If running
Gradekeeper from a floppy, make a backup by dragging the disk icon onto
the hard drive icon.  This will create a folder on the hard drive that
contains the program and your classes.

Windows Users: To backup your classes:

• Insert a floppy disk into the disk drive

• Click the right mouse button on each class

• Choose Send To from the pop-up menu that appears

• Choose 3 1/2 Floppy from the sub-menu that appears

Keeping paper copies of your gradebook is also encouraged.  This would
allow the reconstruction of grades should the data and your backups ever
be lost.
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Grade Computation

Curving an Assignment
Curving an assignment means adjusting student scores on that assignment
to fit the distribution of grades you want. This is usually done to
compensate when an assignment was more challenging than expected.

You can curve an assignment by changing its points possible.

First, change the points possible for the assignment to a value that best
reflects how students actually did on the assignment. You may want to
choose a value that is about the same as the highest score earned on that
assignment. When the program offers to scale student scores, click No.

Next, change the points possible for the assignment back to the original
value. When the program offers to scale student scores, click Yes. This will
scale the student scores proportionally.

Computing Grades
Gradekeeper normally determines grades using total points earned.  The
sum of the points earned is divided by the total points possible.  The result
is converted to the nearest tenth of a percent.  This percentage is then
used to determine a letter grade based on the current letter grade
percentages.

Extra credit assignments (assignments in the Extra Credit category or
assignments with zero points possible) contribute to each student’s points
earned, but do not contribute to the total points possible.

For example:

It All Adds Up 7/ 10

Orient Express 10/ 10

Bulgarian Solitaire 8/ 10

Spirograph Special 8/ 10

Extra Credit Work 10/  0

Chapter 1 Homework 25/ 35

Chapter 1 Test 73/100

Total 141/175 = 80.6%

If certain kinds of assignments (such as tests or homework) are to
contribute a fixed amount to each student’s grade, then grades should be
computed using category weights.  The percentage correct within each
category will be computed, with grades being determined by a weighted
average of the percentage correct within each category.



57

Grade Computation (cont.)

Extra Credit
Extra credit assignments can affect grades in different ways when
computing grades using category weights.

You should not put assignments with 0 points possible into the Extra
Credit category. This would make it possible for a student to earn more
than 100% on extra credit assignments, and could result in those
assignments making no contribution to the grade. Gradekeeper will warn
you if you give an extra credit assignment 0 points possible.

The following is a detailed example of grade computation using category
weights when you have extra credit assignments:

Tests Chapter 1 Test 82/100
Chapter 2 Test 80/100
Chapter 3 Test 78/100
Total 240/300 = 80%

Homework Chapter 1 Homework 30/ 40
Chapter 2 Homework 20/ 30
Chapter 3 Homework 40/ 50
Total 90/120 = 75%

Activities Spirolaterals 8/ 10
Spirograph Special 7/ 10
Total 15/ 20 = 75%

Extra Credit Math Counts #1 7/ 10
Math Counts #2 3/ 10
Total 10/ 20 = 50%

Tests 80% correct  x  50 weight  =  40.0%

Homework 75% correct  x  30 weight  =  22.5%

Activities 75% correct  x  20 weight  =  15.0%

Extra Credit 50% correct  x  10 weight  =   5.0%

Total 100 weight  =  82.5%

Without the assignments in the Extra Credit category, this student would
have earned a grade of 77.5% for the term. Note that the Extra Credit
category is not included when the category weights are totaled. This is
what makes these assignments truly extra credit.
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Semester Grades
Semester grades are computed by averaging term grades. Final grades for
the year are computed by averaging semester or trimester grades. All
averaging is done using percents.

For example:

1st Quarter 81%

2nd Quarter 75%

3rd Quarter 82%

4th Quarter 86%

1st Semester (81% + 75%) ÷ 2 = 78%

2nd Semester (82% + 86%) ÷ 2 = 84%

Final (78% + 84%) ÷ 2 = 81%

Grade computation includes final exam grades as specified in your school
year options. For example, if final exams are 30% of the term grade, and a
student earned 75% on the exam:

Term Grade 81% x 70 = 56.7

Final Exam 75% x 30 = 22.5

Grade 
(including Exam) 79.2%
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Final Exams 
If final exams are 20% of the semester grade, and a student earned 72%
on the exam:

Semester Grade 78% x 80 = 62.4

Final Exam 72% x 20 = 14.4

Grade (including Exam) 76.8%

You may choose different categories, weights, and grading options for
each term in the school year. This gives you the flexibility to change how
you compute grades during the course of the school year.



60

Programmer’s Notes
I wrote Gradekeeper because I was unable to find an inexpensive grading
program that had the features I wanted and was also easy to use.  I hope
Gradekeeper will fill that void for you as well.

Special thanks to my fellow teachers for their many comments and
suggestions, which have helped make Gradekeeper so friendly and
powerful.  Comments and suggestions are also appreciated.  I can be
reached at:

info@gradekeeper.com

For more information and the latest version of Gradekeeper, or to
purchase a site license, visit the Web site at:

http://www.gradekeeper.com

Daniel Ethier
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